Home javascript android java php c# ubuntu python c++ c ios TAGS

In project 'app' a resolved Google Play services library dependency depends on another at an exact version (e.g. "[


Date : 2019-06-12 13:49:31 , By : fazil

I tried to add the SSO to my project I referred this link sso

After adding this line in build.gradle(Module:app)

//Microsoft
implementation 'com.microsoft.identity.client:msal:0.2.+'

am getting the following error

   In project 'app' a resolved Google Play services library dependency depends on another at an exact version (e.g. "[1.3.1
,2.3]", but isn't being resolved to that version. Behavior exhibited by the library will be unknown.

Dependency failing: com.nimbusds:nimbus-jose-jwt:5.7 -> net.minidev:json-smart@[1.3.1,2.3], but json-smart version was 2
.3.

The following dependencies are project dependencies that are direct or have transitive dependencies that lead to the art
ifact with the issue.
-- Project 'app' depends onto com.microsoft.identity.client:msal@0.2.+
-- Project 'app' depends onto net.minidev:json-smart@{strictly 2.3}
-- Project 'app' depends onto com.nimbusds:nimbus-jose-jwt@{strictly 5.7}
-- Project 'app' depends onto com.microsoft.identity.client:msal@{strictly 0.2.2}
-- Project 'app' depends onto com.microsoft.identity:common@{strictly 0.0.8}

For extended debugging info execute Gradle from the command line with ./gradlew --info :app:assembleDebug to see the dep
endency paths to the artifact. This error message came from the google-services Gradle plugin, report issues at https://
github.com/google/play-services-plugins and disable by adding "googleServices { disableVersionCheck = false }" to your b
uild.gradle file.

build file (Module:app) //

FireBase
    implementation 'com.google.firebase:firebase-core:15.0.2'
    implementation 'com.google.firebase:firebase-messaging:17.6.0'
    implementation'com.google.firebase:firebase-auth:16.1.0'


    // GMS:play-services
        implementation 'com.google.android.gms:play-services-flags:16.0.1'
        implementation 'com.google.android.gms:play-services-basement:16.0.1'
        //Constrain layout
        implementation 'androidx.constraintlayout:constraintlayout:1.1.3'

        //Microsoft 
        implementation 'com.microsoft.identity.client:msal:0.2.+'

So can some one suggest me how to resolve this issue Also I tried following things

I tried the following things 1 Updated the google play services in SDK manager 2 Updated SDK build tools in SDK manager

So can some one suggest me how to resolve this issue

TAGS : android
Answers :
By : devDeejay

Disabling Google Play Services Version is a potential solution. In your app.gradle

apply plugin: 'com.google.gms.google-services'
googleServices {
    disableVersionCheck = true
}
- Technology - Yellow pages
» java
» php
» c#
» ubuntu
» python
» c++
» c
» ios
» jquery
» html
» sql
» r
» mysql
» linux
» access
» iphone
» css
» excel
» vb.net
» .net
» ruby
Privacy Policy - Copyrights Notice - Terms - Contact Us 2019 © tinytut
Licensed under cc by-sa 3.0 with attribution required.